Wait for it!

Sheerness, England. 2022

Click to enlarge image.

Leica M6, Summicron 35mm f/2 ASPH on Kodak Pro Image 100 film.

I love the look on these Spaniels faces.


So my Leica M6 is no more.

I took the above picture last month on the M6. This was one of a few films that were not fogged, indeed Weekend Races image was from the same roll of ProImage. Despite being returned a couple of times for repair the fault kept arising as you can see below. As you can see the problem was still there and was getting worse with each new roll exposed.

Click to enlarge images.

On side note, I noticed I’ve been having issues with white spots on my negatives. This turned out to be my fixer, which I hadn’t noticed was dated 03/2020 …oops! Then I found in my photo cupboard another black concertina bottle from my late father, marked ‘fix’ and dated 2007. This is what came out of the old bottle below, glad I didn’t use it. The black fragments in the sink make me think the inside of the bottle had been slowly deteriorating.

Anyway, back to the M6 issue. It went back to the dealer again and this time I was offered a full refund. But then thinking about it, was only another £1600 ($2,100) for a new ‘M’ body. So I am now the very proud owner of a shiny new chrome MP. Wish I’d done this in the first place but I was stupidly thinking it cannot happen to me again and the first few rolls seemed alright with the M6. I did ask what they where going to do with my faulty M6 and was told it would be sent back to Wetzlar, Germany for an complete overhaul.

Expensive I know at £4100.00 ($5395.00) but it’s not second hand, comes with a year warranty plus an extra year if you register the camera with Leica AG and top and base plate are made of brass not zinc.


Black and white images, Leica M6, Summicron 35mm f/2 ASPH on Fomapan 400 film rated at an ISO of 200.

3 thoughts on “Wait for it!”

  1. I’m sorry to hear about the M6, but congratulations on the new MP. I thought you were done with film when you bought the digital Leica.
    Your blog disappeared for a while. Or was that a problem on my end? Anyway, I’m glad to see your posts again.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s